Current stable version?


#1

Just wondering what the latest stable version is. An update notice showed for version 7.11 (v196.7 r336351) so I upgraded from 7.10 but there seem to be a lot of odd things happending now: imported images disappeared then appeared. Now trying to move objects and the point of rotation is well away from the center of the object. Also have had a few ‘hangs’ requiring a Force Quit.


#2

I was trying to add direction pointers, too, but had to stop doing that because every time I tried to resize the group, it locked (wheel of death). [tried four times and each time, same thing] Quit that and …

So just drawing a line (tracing a sketch) and made it to second image. Boom, spinning wheel of death again.


#3

I restored 7.10.2 and all is working again. Whew!


#4

We have put out a dot release, which may resolve some issues.

I haven’t heard anything about this rotation issue or hangs that you mention. Please email us an example, if you can, so that we can take a look and get this fixed! Choose Contact Omni from the help menu. If there is private data inside, you can choose Anonymize which will replace the text with the letter x.

Thanks,
Lanette


#5

Just got 336882 and using it. I will let you know if problem reappears.

Wish I could send a small file to show issues! Seems it only happens when I have a lot of imported graphics and the file is around 40MB (currently back down to 22MB since I finished some of the tracing).


#6

Okay. Just used for a little while and got another SWoD (Spinning Wheel of Death). I was going to send you the test file I created afterwards which I created by restarting OG Beta and dragging a stencil onto the canvas. After dragging on, the selection box was not around the group of objects; it was above and left of the group. When I clicked on the group, the entire canvas turned grey. I saved the file and closed. When I re-opened it, everything seemed fine.

Should I send anyway? I can send both test file and stencil file (getting interesting behavior out of some of the stencils drawn there then dragged onto canvas but all seems good if I draw them on my drawing then copy them into the stencil file).


#7

Please send anything that will help us isolate the problem so that we can fix it. I’m sorry for the trouble!


#8

Sending stencil file to start.


#9

Thank you! If you can recreate that selection problem, a screenshot would be helpful as well.


#10

I see the problem with groups of lines in your stencil. When you select an item inside a group, you do get the greyed out effect by design. I am not seeing a spinning wheel of death though. Have you seen that issue again? If you can help me figure out how to reproduce it, it’s much more likely we can fix it promptly.

Thanks,

Lanette


#11

I just experienced this as well. I believe the SPoD occurrence was preceeded by a program (Microsoft) attempted to update in the background, eating up system resources. I believe this because an Excel update existed … half-installed but stalled.


#12

I am not an Excel user so that wasn’t it for me.

I did notice the one time I was able to re-create the SPoD, I had multiple apps open (FireFox, Mail, Grab, OG, OmniOutliner). In my usual operating mode, I have more apps running (Safari, Calendar, Contacts, Reminders, AccountEdge plus above) and it appeared to occur more often.

I will continue to try and recreate.


#13

Do you know if you had multiple OmniGraffle documents opened at the time? Was there just one file open in OmniGraffle? We have reproduced and fixed one crasher here in house, but want to be sure that we have fixed all lingering cases. Thank you for working with us to get this solved.


#14

If I had another document open, it would have been the stencil file. But I’m pretty sure i just had my work file open.

When I got the one crash/SWoD to re-occur this morning I only had one file open. Of course, I couldn’t reproduce it a few seconds later. Even had QuickTime ready to go!


#15

After I updated to 7.11 I also experienced lots of new bugs. Here’s one that still exists even after updating to 7.11.1 – table cells no longer resize to fit contents (or the rows they’re in don’t resize). Screencast: https://recordit.co/FOKGu4DxbP

I also had tables where the rows collapsed to a few pixels tall for no reason, and tables where certain cells were unselectable even if I clicked right on them. I can’t recreate those bugs now.

I also still have the “Fit in Window” problems I reported in the past.


#16

Thank you for the clear bug reports. I’ve made sure the table issue has been reported now. These issues are different from the stability problems others have reported, but thank you for letting us know about them and sorry for the difficulty.

I’ll look into the “Fit to Window” situation and let you know what I’ve found and if there is a workaround until we have a fix.

Thanks,

Lanette


#17

Did you end up going back to 7.10.2? I can reproduce the Fit in Window bug there when rulers are not showing, but not in 7.11.1 where I am seeing the problem with fit to window without the ruler is resolved. What version are you seeing that in? I can reproduce in 7.10.2, but not 7.11.1 or higher.

Fit in Window is a per canvas mode. If you zoom in or out, it is turned off for that canvas. If you have it on, it should stay on for that canvas until/unless you zoom to a different level. The part that was a bug is there was a gap at the top when rulers were hidden, but that bug fix is only in 7.11 and higher.


#18

Only thing I have seen with “Fit in Window” it it resizes using all layers, not just visible layers. If I have a really large section on one layer but make it invisible and use “Fit in Window”, the image shrinks (zooms out) as if the other layer was still visible (You can try this with the file I just uploaded to Christian on the Adding Nodes issue).


#19

I was able to get the SWoD, captured Log and eMailed. Yeah?


#20

Is 7.11.1 stable enough for everyday work or should I keep using 7.10.2?