Disabling Auto-save on Mac OS Big Sur 11.4

Dear All,

I have just upgraded to Mac OS Big Sur 11.4 and Omnigraffle starts to auto-save my files every few minutes again (I may have previously disabled the feature but forgot how and when I did it). My files are usually larger than 30MB and it takes at least a minute to save, which means I am being interrupted every few minutes for at least a minute whenever I am working on an Omnigraffle document. Therefore I am looking for a way to disable such feature.

I have tried typing in Terminal the following command:
defaults write com.omnigroup.OmniGraffle7 ApplePersistence -bool no
While Terminal did returns that the function is disabled, it does not have any actual effect on the auto-saving behaviour in Omnigraffle.

I wonder if anyone knows a workaround? Thank you very much in advance!

Omnigraffle Version: Standard Version (7.18.5)

I have the same issue under 10.14.6. Most annoying how often OG interupts work to implement a save. Woul d love to turn off AutoSave. I would love to be able to control the AutoSave from the Preferences pane so I could turn on/off or set an interval.

What version of OG are you running?

Dear ScoutsHonor,

I am using OG 7.18.5. I also tried 7.11.5 but still the same.

I believe this problem has bothered numerous users for a long time. I just emailed support.

I would like to thank Omnigraffle Support’s reply as follow:

Hello Kelvin,
Sorry for the trouble here, but thanks for getting in touch! I’m afraid there is not currently a way to disable auto-saving in the app. There used to be a way of doing this using a Terminal command, but that no longer works on newer releases of macOS.
We’ve had reports of slowness and even crashing during save since macOS 11.3. The trouble is being caused by a bug introduced to a macOS framework (NSPropertyListSerialization) that OmniGraffle uses when saving. This bug makes this framework ~200x slower or it will just fail sometimes. The more individual objects you have in a document, the slower saving will be.
This bug has been reported to Apple. While a fix has not come as quickly as we’d like, it is looking like macOS 11.5 (currently in beta) should address this problem.
For now, if it is possible for you to revert back to macOS 11.2.3 or earlier, that would be the only way to truly avoid this issue for now. This should be possible if you use Time Machine to backup your Mac. Here is an article that describes how you should be able to downgrade to the last OS revision you were running:
Note: That article talks about downgrading from 11.2 to 11.1, but the procedure shown applies the same now.
Outside of that, the only thing you can do to try to mitigate this issue would be to split up your document into smaller separate documents. Obviously that may not be at all feasible depending on the actual content of your document. A case where it would be more doable (though obviously still not ideal), would be if you have multiple canvases in a document, you could split out each canvas into its own separate document.
Sorry I don’t have better news at the moment. If you do have any other questions/concerns for us right now, just let me know.
Email Support Lead
Omni Group

I also eMailed tech support about the issue since it causes slow downs in MacOS prior to 11, too. I just want to be able to turn on/off in the Preferences pane.

Their reply:

Hi Richard,

Thanks for getting in touch! We do have a feature request for an option to disable auto-save, and I’ll get you added to that.

If you have any additional suggestions, questions or concerns, please don’t hesitate to let me know. We really appreciate your input and support!

For what it is worth.
AFAIC Tim Cook is destroying the company from the inside. With every release, the OS gets more restrictive. I am still on MacOS 10.10.5, on fairly new hardware.

The apps are getting more and more schizophrenic with every release, the GUIs is the worst ever. As a UX expert, let me assure you they are training you to be distracted; to work harder; to maintain confusion; to look for things in the wrong place. When I first bought this unit, and found that Apple had removed features in iWork that I use.

As a result of a support call, they shipped me iWork '09. No kidding, it is full-featured and faster. Except, it was a CD. I had to buy a CD/DVD drive just to read it.