New task: avoid setting default constraint "start no earlier than"


#1

When I create a new task, by default this task gets a “start no earlier than” today constraint.
How can I remove this default behavior?

I do not want to see the slack in the GANTT between today’s date and the actual scheduled start date.


#2

@wivaku It sounds like you may need to update your default task attributes! To do so, create a task that does not have this constraint set, then select Project > Set as Default for New Tasks in the OmniPlan menu bar.


#3

Interesting, I was not aware of this function. Thanks!
However, when I tried it just now it did not change the behavior. I created a new task, removed the “start no earlier than” constraint, selected Project > Set as default for new tasks, and then pressed enter to create a new task. The new task still had the “start no earlier than” constraint. Using OP 3.1 (v179).


#4

how to reproduce (for my installation):

  1. create new file
  2. first task is without “start no earlier than” constraint, same for any other tasks that are created
  3. change the project start date to a date in the past (e.g. 10/1/2015)
  4. create a new task, now the “start no earlier than” constraint is set to today (8:00 in the morning)

#5

Here’s a couple different ways to accomplish this, depending on your goal:

  1. Turn on “Automatically level resources” and turn OFF “Don’t schedule any task before now” (in the sheet that appears when you click the Level toolbar button)
  2. Set Current Editing Date… (in the project menu)

#6

Thanks lizard, however I don’t think your suggestions accomplish what I was looking for.

  1. automatically level resources: I do not want to level resources. Plus, when I do this it does not change the behavior for either old or new tasks.
  2. set current editing date: this means the constraint is still added, but it does not use today’s date but the manually set date, right? In that case it is extra work, and the same result.

Here is the picture of what I mean.
a) I only want to set the “start no earlier” constraint when I really want it. When I move something to another day, or when it is created for today, it means that that is the (expected) actual date. Start no earlier is something else.
b) I only want to see the constraint bars when I have explicitely set the “start no earlier” than constraint. Now the bars are distracting and incorrect.


#7

@lizard / @ains: suggestions?


#8

I’m assuming that since two Omni staff haven’t been able to provide an answer to this that it’s not possible in the current version? Is it currently recorded as a bug or do we need to email support@omnigroup.com? I call it a bug because i think in the past, the solution mentioned at the top of this thread worked, but it definitely doesn’t now, and I agree, it is annoying!


#9

Agreed. I believe it is the same behavior in v2.4. Have not reported it to support.


#10

@TimTottenham @wivaku Sorry this fell off my radar! If you’re still seeing this behavior in the most recent version of OmniPlan for Mac, it would be great if you could email Support (omniplan@omnigroup.com)!

Thanks!


#11

Hello, I have the same problem I think. Omnifocus (2) adds a constraint to all my tasks. Even if I try |Project > Use as default for new tasks setting|

The problem occurs when editing a project with a start date after today, which is almost every time. Is this expected behaviour, can it be changed?


#12

@jceelen Sorry for the trouble! I’m unable to reproduce this behavior on my Mac however - would it be possible for you to send an email to our Support team so that they can look into this with you further! They can be reached at omniplan@omnigroup.com. Thanks!


#13

When adding new tasks to a project whose start date is in the past, OmniPlan assumes that the new task can’t have been accomplished in the past, so a start constraint of the current date is added to the task by default.

Currently there are two methods to avoid this:

• Remove the start constraint after the fact, or

• Change the current editing date (to the task’s desired start date), prior to adding new tasks, by selecting Menu Bar ▸ Project ▸ Set Current Editing Date…

We do have a request open for a preference to customize this behavior. If you’d like to add your thoughts to the feature request, please email us. Sorry for the frustrations in the meantime!


#14

In the last 2 years has there been any progress on this?
I don’t want to always see this Set No Earlier Than anywhere and yet it always appears. Cannot make it go away.


#15

This behavior drives me insane. It seems counterintuitive to have the default behavior be to assign start constraints based on the current editing date. I would prefer to have no constraints assigned by default and manually add them when I need them. Removing them for projects which started in the past or which will start in the future are needless work for me.

Can an update on this feature change be provided?


#16

@cool1o @mcescher I don’t have an update to provide on this behavior at the moment, but it is helpful to hear that this is something you would both like to see changed in a future update! I’ve attached your posts to our open request to change this behavior.

@cool1o If you simply don’t want to see these constraints in the Gantt chart, you can hide them by unchecking the View > Gantt > Constraints menu item.


#17

Thanks @ains, that worked just fine!