OmniFocus 2.1 Test Builds

Compact view is still buggy - In quick entry I can’t add a flag, due or deferred dates. Anyone else having this problem?

Update: Looks like I can’t add flags in any view by clicking on the little flag area on the top right corner of the check-mark circle.

I’m sorry for the really silly question – but how does one enable compact view (or is it just ‘on’ by default)?

I’m running 2.1 test (v92 r224365)


You can learn more about the compact view (including how to turn it on and off) from this post:

Please be sure to email your feedback so our Support Humans can file bugs for our development team! Help->Send Feedback will get it to the right place and tell us exactly which build you’re using.

I seem to have no trouble filling in Due by tabbing over to it, but it does seem to skip right past Deferred and I can’t seem to click on either field.

Not sure what’s up with clicking on the flag right now, but you can always flag the current item using the keyboard shortcut Shift-Command-L (Edit->Set Flag).

Thanks Ken. I did send in feedback, thanks for the reminder.

I haven’t used the keyboard shortcut before for setting a flag - works just fine in quick entry, will do for now. However, I can’t seem to tab past context. I can use tab to select task name, project, and context, but then a fourth tab press just highlights the entire row. Am I doing something wrong?

Thanks Ken, that got it!

I think if the window width is small, you can’t tab into a field like the defer date field. As noted previously, the compact view is still in the experimental stage and is not fully finished. Don’t expect it to work quite as smoothly as the default layout view.

Got ya. Will hang tight until it becomes an ‘official’ feature. Cheers

I like the improvement of the “Mark Reviewed” button group in Review perspective:




Today widget has stopped working with the latest beta - showing previously completed tasks as available and totally unresponsive. Anyone else seeing this?

Hopefully only after they fix the UI functionality - otherwise, it’ll break connectivity with OF1.

From the post at the top, it sounds like even 2.1 won’t address the issues :-(. More lipstick, still no bacon, if you catch my drift.

Yes, same here. it seems that it is crashing. I already sent the crash log to OmniGroup.

no it is best because i used this


Yes, same here.

Since the Jan 21st build I can’t even launch any the of OF test builds - they crash on launch. Tried logging out/in. Anyone able to help?

Contacting support via email ( is probably the quickest way to get you back up and running. Sorry to hear about the crashing!

The latest version #225135 has not helped - widget now showing tasks from 2 days ago!

Same for me. Hopefully I’ll hear back from support soon.

Me too. I’m using a MacBook Air. Maybe that’s the problem.

I don’t think so. I’ve tried it on my iMac and Mac mini, and get the same problem on both.