OmniFocus 3 with Outlook 2016


#1

Does anyone have any Outlook Email Scripts that are working with OmniFocus 3?
The scripts that I was using with OF2 are causing issues.


#2

See this thread

I just tested the Alfred workflow incorporating the script. It works.


#3

Does this work with omnifocus 3? To be clear, there was an updated one by @zzamboni, and it looks like that one broke.


#4

@checkingthingsout - my script (here) has continued to work with OmniFocus 3. What problem did you have with it?


#5

@zzamboni back in the days of older outlook and older OF, even if you were using the Outlook Mac Application (rather than hitting outlook in a web browser) it would include a link to the email. So from OF I could double click that link and open up the explicit email that I’d previously captured.

Is this now impossible since Outlook removed native AppleScript support? Was nice to be able to open the exact email to respond to from OF. =)


#6

Yes it works with OmniFocus 3. I used it this morning.


#7

This is the error I am getting with OF3 with zzamboni’s script.

Exception raised while sending -willSave: Unable to fulfill fault: Error Domain=com.omnigroup.framework.OmniDataObjects.ErrorDomain Code=10 “Unable to fulfill fault.” UserInfo={com.omnigroup.framework.OmniBase.ErrorDomain.FileLineAndNumber=/Users/Shared/omnibuild/ReleaseProduct/Source/OmniGroup/Frameworks/OmniDataObjects/ODOEditingContext-Internal.m:549, NSLocalizedDescription=Unable to fulfill fault., NSLocalizedRecoverySuggestion=Object with ID ‘<ODOObjectID:0x600000836ca0 Attachment/ljygBWAOqsE>’ is inaccessible.}


#8

So with any scripts for Outlook there are a number of ways to do this.

  1. use any third party app for activating apple script.
  2. Use Automator to create an automated script, and then tie it to a shortcut. There are a number of HowTo’s on the web for AppleScript in Automaker and shortcuts.

#9

I am using it in Alfred. Basically what I am saying is this script from @zzamboni works with Alfred/OF2 but not Alfred OF3.


#10

@checkingthingsout OK - I just noticed I’m getting the same error as you. My Chrome-to-OF script is also not working. This was working a few days ago, so it must be some recent change in OF3. I’ll take a look ASAP.


#11

Thank you - you are incredible.


#12

@zzamboni
I just put your script as is in to my system and it works. I am activating it via AppleScript directly from “BetterTouchTool”


#13

@checkingthingsout it seems the problem is in the quick dialog entry. If you pass the “nodialog” argument to the script, then it works fine for me. For example, the following gives the error:

osascript outlook-to-omnifocus.applescript

But the following works:

osascript outlook-to-omnifocus.applescript nodialog

There must have been some change in the quick entry AppleScript interface which I have to figure out.

@yury: I’m glad the script works for you! Not sure what the difference is. Maybe slightly different versions of OF3?


#14

Isn’t the problem that without the quick entry you can’t direct where the action goes?


#15

Glad to see this discussion. I emailed support a few days ago because my Outlook to OF script has also broken in OF3 and it seems related to the quick entry panel. This very simple script reproduces the problem:

tell application “OmniFocus”
tell quick entry
set _task to make new inbox task with properties {name:“yeye”}
end tell

If I run this and then invoke the quick entry window, the task is there, but hitting “save” does not add it to the inbox like it used to, or to anywhere else in OF. Setting a tag for the task in the quick entry panel causes OF to crash.


#16

I’m also somehow not seeing this line in the script.


#17

@checkingthingsout without the quick entry dialog, the task gets put directly into the Inbox, from where you can classify it. Also, the line I showed is not in the script - it’s an example for how to execute the script from the Terminal, using the osascript command, with and without the nodialog argument. You need to adjust the argument depending on how you are executing the script.

@genecivillico thanks for the minimal example - I see the same behavior (task appears in the dialog, but pressing “Save” does not actually create it).


#18

@zzamboni thank you. I thought the quick entry dialogue you added was an incredibly powerful addition to the script. it would be terrific to preserve it somehow.


#19

@zzamboni cool. I feel like something must be awry here since selecting a tag in quick entry shouldn’t crash OF.


#20

@zzamboni - Ahhh. that might be it. I am using Beta version, which sound like it is fixed.

I guess you might want me to test something… just PM me.