Spotlight not Indexing OmniFocus


Wanted to document some trouble I had getting Spotlight to index OmniFocus (v3.4.4 – 10.14.6). Normally you can look up actions in Spotlight and clicking on them takes you to the encompassing project.

I did two things that worked in sequence, but not when I first tried them independently.

  • I found I had no ~/Library/Caches/Metadata folder on my (relatively new) iMac. Checking my older laptop, where Spotlight indexing was working, OmniFocus does store metadata files there which I guess are used for Spotlight. So I created the folder manually on my iMac. Nothing seemed to happen.

  • Since this is now a common troubleshooting step in macOS, I tried giving OmniFocus full disk access in System Preferences > Security & Privacy. This prompts you to restart OmniFocus.

I had earlier enabled and disabled full disk access without luck, but trying it again after creating the ~/Library/Caches/Metadata folder got it working. OmniFocus created a subfolder and filled it with metadata files.

Oddly, removing full disk access did NOT cause it to stop working. Still indexes new actions.

Just wanted to post this in cast anyone else has trouble, and maybe OmniGroup can fix it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.