Autolayout won't squish

Greetings folks, a quick query.
The elements in the attached screenshot should be nearly horizontally touching. I’ve changed the spacing to 1mm and even 0mm, but autolayout refuses to narrow the space. Any idea how to resolve?

Not a user of AutoLayout but can try it out later today. Can you post the actual graffle file here or does it contain private info?

What version of OG are you using?

Thanks for replying. I’m running 7.18 (v204.4.0).
I simplified the file for easier analysis. See what you think. It seems like auto’s willingness to squish things in one direction is some influenced by the spatial requirements demanded by the other, but it doesn’t really factor into what is going on here. I need to maximize the horizontal space. Uploader.graffle (219.5 KB)

I will try to take a shot at it later today

(Not an answer, just an explanation.)

I have many diagrams that contain hierarchies, some identical to yours, others more detailed, using objects.

OG V4 had an AutoLayout feature that worked reasonably well, it allowed the user to specify a StyleSheet (previously drawn of course, same as a Template, but for relevant spacing; etc).

We lost that feature in OG V5. They implemented some supposedly automatic laying out of objects, but it has never worked for me. None of the auto layout options work for me.

OG V6 auto layout is no better or worse than OG V5.

I use OG V5 exclusively. And I layout my hierarchies manually.

Shows what I expect you are attempting, but with the text running horizontally, and using objects not text boxes. Manual layout on the left, OG V5 AutoLayout on the right, the best one after trying all options.
AutoLayout Trial.pdf (214.9 KB)

The geometry of the shapes themselves will constrain how close the text can get.

Only the text is visible here, but each shape does nevertheless (see the geometry inspector) have non-zero width/height, and may also contain blank lines trailing the visible text.

A zero gap in auto-layout specifies separation of the (invisible) enclosing shapes, not of the (visible) text they contain.

i.e. you can tighten the text separations by trimming down the shapes in which they are embedded.

You may also need to adjust or remove the magnets to which the connectors are attaching.


thanks @draft8 - that seems like the solution. when I get this thing done ill get it posted. cheers!

1 Like